The service degradation has been resolved. Thank you for your patience.
Posted Feb 12, 2026 - 00:53 UTC
Update
We are continuing to work on a fix for the service degradation.
Posted Feb 11, 2026 - 23:32 UTC
Update
We are continuing to work on a fix for the service degradation and Hub issue
Posted Feb 11, 2026 - 21:35 UTC
Update
We are continuing to work on a fix for the service degradation and Hub issue. We appreciate your patience and this is our highest priority to resolve.
Posted Feb 11, 2026 - 18:02 UTC
Identified
We have identified a service degradation and are actively working on a resolution.
Posted Feb 11, 2026 - 16:00 UTC
Investigating
We have identified a service degradation and our team is actively working on identifying a resolution.
Posted Feb 11, 2026 - 15:24 UTC
This incident affected: SIM Management (Monogoto Hub) and Connectivity (Identity U (USA), Identity B (Global), Identity E (Global), Identity O (Global)).