Technical Failure Notification: May 13th, 2026

Incident Report for Monogoto Status Page

Resolved

Service has fully recovered and stabilized. All profiles are operating normally. Our team will continue to monitor to ensure continued stability. We apologize for the disruption and thank you for your patience.
Posted May 13, 2026 - 21:50 UTC

Identified

We are currently in a recovery process and seeing improvement across our profiles. Our team continues to monitor closely as service stabilizes. We will provide further updates as recovery progresses. Thank you for your patience.
Posted May 13, 2026 - 21:19 UTC

Investigating

We have identified a service degradation and our team is actively working on a resolution.
Posted May 13, 2026 - 19:43 UTC
This incident affected: Connectivity (Identity U (USA), Identity B (Global), Identity E (Global), Identity O (Global), Indentity P (IL), Indentity C (IL)).